科技行者

行者学院 转型私董会 科技行者专题报道 网红大战科技行者

知识库

知识库 安全导航

至顶网网络频道详解NAT网络地址转换服务配置

详解NAT网络地址转换服务配置

  • 扫一扫
    分享文章到微信

  • 扫一扫
    关注官方公众号
    至顶头条

通过NAR网络地址转换怎么实现内部IP地址和Internet的IP地址转换;了解NAT网络地址转换有集中类型,以及它们在生活中在哪儿应用;

来源:中国IT实验室 2009年4月1日

关键字: 地址转换 网络地址 NAT

  • 评论
  • 分享微博
  • 分享邮件

  网络拓扑:

   

  网络目的:

  通过NAR网络地址转换怎么实现内部IP地址和Internet的IP地址转换;

  了解NAT网络地址转换有集中类型,以及它们在生活中在哪儿应用;

  了解NAT网络地址转换的作用和原理;

  简单了解一下TCP负载均衡;

  网络连线:

  Router1 E0/0 <----> Router2 E0/1

  Router2 E0/0 <----> Router3 E0/1

  Router3 E0/0 <----> Router4 E0/1

  Router4 E0/2 <----> VPCS V0/1

  Router1 E0/1 <----> XPC P0/1

  网络步骤:

  ————路由器的一些详细配置————

  1.配置路由器1的IP地址;并为路由器1配置一条默认路由;(配置默认路由的原因就是让来学习相邻的网段)

  r1(config)#interface e0/0

  (config-if)#ip add 100.100.100.1 255.255.255.0

  r1(config-if)#no sh

  r1(config)#interface e0/1

  r1(config-if)#ip add 172.16.2.126 255.255.255.0

  r1(config-if)#no sh

  r1(config-if)#ex

  r1(config)#ip route 0.0.0.0 0.0.0.0 e0/0

  2.配置路由器2的IP地址,然后用来宣告他的网段(我们可以用RIP、OSPF、静态来宣告路由器直连的网段,在这里我们选用我们所学习过的RIP;在这里我们用路由器1和路由器2模拟INTERNET)

  r2(config)#interface e0/1

  2(config-if)#ip add 100.100.100.2 255.255.255.0

  r2(config-if)#no sh

  2(config-if)#ex

  r2(config)#interface e0/0

  r2(config-if)#ip add 101.101.101.1 255.255.255.0

  r2(config-if)#no sh

  r2(config-if)#ex

  r2(config)#router rip

  r2(config-router)#version 2

  r2(config-router)#no auto-summary

  r2(config-router)#network 100.100.100.0

  r2(config-router)#network 101.101.101.0

  3.配置路由器3的IP地址,然后用RIP宣告路由器3直连的网段;我们在这里所用的是RIPv2来进行配置:

  r3(config)#interface e0/1

  r3(config-if)#ip add 101.101.101.2 255.255.255.0

  r3(config-if)#no sh

  r3(config-if)#exit r3

  r3(config)#interface e0/0

  r3(config-if)#ip add 102.102.102.1 255.255.255.0

  r3(config-if)#no sh

  r3(config-if)#exit

  r3(config)#router rip

  r3(config-router)#version 2

  r3(config-router)#no auto-summary

  r3(config-router)#network 102.102.102.0

  r3(config-router)#network 101.101.101.0

  4.配置路由器4的IP地址,然后为路由器4指定默认路由;

  r4(config)#interface e0/1

  r4(config-if)#ip add 102.102.102.2 255.255.255.0

  r4(config-if)#no sh

  r4(config-if)#exit

  r4(config)#interface e0/2

  r4(config-if)#ip add 10.10.10.1 255.255.255.0

  r4(config-if)#no sh

  r4(config-if)#exit

  r4(config)#ip route 0.0.0.0 0.0.0.0 e0/1

  网络拓扑:

  网络目的:

  通过NAR网络地址转换怎么实现内部IP地址和Internet的IP地址转换;

  了解NAT网络地址转换有集中类型,以及它们在生活中在哪儿应用;

  了解NAT网络地址转换的作用和原理;

  简单了解一下TCP负载均衡;

  网络连线:

  Router1 E0/0 <----> Router2 E0/1

  Router2 E0/0 <----> Router3 E0/1

  Router3 E0/0 <----> Router4 E0/1

  Router4 E0/2 <----> VPCS V0/1

  Router1 E0/1 <----> XPC P0/1

  网络步骤:

  ————路由器的一些详细配置————

  1.配置路由器1的IP地址;并为路由器1配置一条默认路由;(配置默认路由的原因就是让来学习相邻的网段)

  r1(config)#interface e0/0

  (config-if)#ip add 100.100.100.1 255.255.255.0

  r1(config-if)#no sh

  r1(config)#interface e0/1

  r1(config-if)#ip add 172.16.2.126 255.255.255.0

  r1(config-if)#no sh

  r1(config-if)#ex

  r1(config)#ip route 0.0.0.0 0.0.0.0 e0/0

  2.配置路由器2的IP地址,然后用来宣告他的网段(我们可以用RIP、OSPF、静态来宣告路由器直连的网段,在这里我们选用我们所学习过的RIP;在这里我们用路由器1和路由器2模拟INTERNET)

  r2(config)#interface e0/1

  2(config-if)#ip add 100.100.100.2 255.255.255.0

  r2(config-if)#no sh

  2(config-if)#ex

  r2(config)#interface e0/0

  r2(config-if)#ip add 101.101.101.1 255.255.255.0

  r2(config-if)#no sh

  r2(config-if)#ex

  r2(config)#router rip

  r2(config-router)#version 2

  r2(config-router)#no auto-summary

  r2(config-router)#network 100.100.100.0

  r2(config-router)#network 101.101.101.0

  3.配置路由器3的IP地址,然后用RIP宣告路由器3直连的网段;我们在这里所用的是RIPv2来进行配置:

  r3(config)#interface e0/1

  r3(config-if)#ip add 101.101.101.2 255.255.255.0

  r3(config-if)#no sh

  r3(config-if)#exit r3

  r3(config)#interface e0/0

  r3(config-if)#ip add 102.102.102.1 255.255.255.0

  r3(config-if)#no sh

  r3(config-if)#exit

  r3(config)#router rip

  r3(config-router)#version 2

  r3(config-router)#no auto-summary

  r3(config-router)#network 102.102.102.0

  r3(config-router)#network 101.101.101.0

  4.配置路由器4的IP地址,然后为路由器4指定默认路由;

  r4(config)#interface e0/1

  r4(config-if)#ip add 102.102.102.2 255.255.255.0

  r4(config-if)#no sh

  r4(config-if)#exit

  r4(config)#interface e0/2

  r4(config-if)#ip add 10.10.10.1 255.255.255.0

  r4(config-if)#no sh

  r4(config-if)#exit

  r4(config)#ip route 0.0.0.0 0.0.0.0 e0/1

  4.在路由器4上先定义ACL访问控制列表;在路由器4上我们只是允许10.10.10.0网段的流量来通过,而拒绝其他网段的流量来通过;我们采用的是标准的访问控制列表,而不是扩展的访问控制列表;它们之间最明显的区别是:标准的访问控制列表的标号是1~99而扩展的访问控制列表的标号是100~199!

  r4(config)#access-list 12 permit 10.10.10.0 0.0.0.255

  3.在路由器4上设置动态的IP地址转换;我们在上面讲解完了NAT的几种状态和NAT的一些专业术语;现在我们来了解NAT网络地址转换的优点和缺点;NAT网络转换的优点是: NAT允许企业内部网络网使用私有地址,并通过设置合法地址池,让内部网可以与Internet来进行通信,以此来达到节约地址的目的;NAT地址转换可以减少规划地址集时地址重接的情况发生;如果地址方案是最初在私网网络中建立的,因为它不与外部网络通信,所以有可能使用了保留地址以外的地址;如果该网想要连接到Internet。如果不做NAT就会发生地址冲突:NAT增强了内部网络与外部网络连接的灵活性:通过地址集、备份地址和负载分担、均衡地址集,来确保可靠性!NAT网络地址转换的缺点是:NAT网络地址转换会增加延迟;因为它要转发每一个数据包中的IP地址,自然就会增加延迟;NAT网络地址转换会增加配置和排错的负载性。NAT网络地址也会因为需要内嵌IP地址的应用而不能正常的工作,那是因为它隐藏了端到端的IP地址。

  r4(config)#ip nat inside source list 12 interface e0/1 overload

  4.在路由器4上配置NAT地址转换;我们在上面刚讲完NAT的三种转换方法那么他们的应用场合是:静态转换运用的场合是:能实现外部网络的对内部网络的中某些特定的设备的访问;动态转换运用的场合是:当ISP提供的合法地址少于网络内部的计算机数量时;端口多路复用是目前运用的最多的转换方式;关于TCP负载均衡的设置,我们在这里说的不是很清楚,负载均衡它是把一个客户机或者服务器上的繁重任务分到多个客户机或者服务器上,然后通过指定一个虚拟的IP地址映射到服务器或者客户端!

  r4(config)#interface e0/1

  r4(config-if)#ip nat outside

  r4(config-if)#interface e0/2 r4(config-if)#ip nat inside

  5.在客户机上来测试看网络是不是互通:

  C:\Documents and Settings\Administrator>ping 101.101.101.2

  Pinging 101.101.101.2 with 32 bytes of data:

  Reply from 101.101.101.2: bytes=32 time=131ms TTL=253

  Reply from 101.101.101.2: bytes=32 time=93ms TTL=253

  Reply from 101.101.101.2: bytes=32 time=109ms TTL=253

  Reply from 101.101.101.2: bytes=32 time=109ms TTL=253

  Ping statistics for 101.101.101.2:

  Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

  Approximate round trip times in milli-seconds:

  Minimum = 93ms, Maximum = 131ms, Average = 110ms

  注意:在中间我们是用路由器来模拟的INTERNET所以他们是不能互相通信的!!!

  VPCS 1 >ping 172.16.2.125

  172.16.2.125 icmp_seq=1 timeout

  172.16.2.125 icmp_seq=2 timeout

  172.16.2.125 icmp_seq=3 timeout

  172.16.2.125 icmp_seq=4 timeout

  172.16.2.125 icmp_seq=5 timeout

  6.在路由器上来查看他的配置是不是正确;看它的联通是不是起作用了!!!下面是我们用NAT来做的一些地址转换!!!

  r1#show ip nat translations

  Pro Inside global Inside local Outside local Outside global

  icmp 100.100.100.1:512 172.16.2.125:512 100.100.100.2:512 100.100.100.2:512

  icmp 100.100.100.1:512 172.16.2.125:512 102.102.102.1:512 102.102.102.1:512

科技行者:每条内容都是头条的新闻客户端 扫码立即下载

    • 评论
    • 分享微博
    • 分享邮件
    邮件订阅

    如果您非常迫切的想了解IT领域最新产品与技术信息,那么订阅至顶网技术邮件将是您的最佳途径之一。

    重磅专题
    往期文章
    最新文章